Forums
November 20, 2017, 12:01 PM

Author Topic: WWP: A real compatibility fix for Windows 10, 8.1, 7, Vista and XP  (Read 66001 times)

0 Members and 1 Guest are viewing this topic.

Offline StepS

[ English | Русский | 日本語 ]


News: Team17 have released Worms World Party Remastered on 16 July, 2015.


Tried different fixes, but WWP crashes on start? Or other problems? Your long internet searches are now over, and here's the solution. :)

Download:
How to install: Extract all the files from the archive to your WWP folder and launch WWP.

Last update: 4 October 2014

This will work on any version of WWP, but I personally recommend to patch it to the latest (1.01).
The HD patch will only work on european 1.00 and 1.01! Make sure you have one of them installed!

This will fix the crash problems in WWP for real on all Windows systems, including Windows 10, Windows 8.1, Windows 7, Vista and XP.

Don't forget to remove all the other fixes (such as "color fixes") if you installed them before! They are not needed as the game runs in 32-bit colour depth now, eliminating the color issue.
The same applies to WWP.exe "compatibility" options in the file properties. It's best to disable them all.

The windowed mode feature will also enable a cool windowed mode. :)



Features:
  • Ability to enable windowed mode both during the match and in frontend menus. Open wndmode.ini and change "WindowedFrontend" and/or "WindowedInGame" from 0 to 1 to enable window. Frontend will be in the top left corner due to technical limitations; the in-game process will be in center of the screen.
  • When in windowed mode during the match, unpin the cursor from the game window by alt-tabbing or pressing Ctrl+G. You can then move the window border (enabled through the "Border" setting in the ini file). Pin it back by clicking inside the window (or using Ctrl+G again).
  • Minimize the game using Shift+Esc, Win+D, Win+M, or any other method you like. For fullscreen this only works when playing the match (to prevent crashes in frontend menus), in windowed mode the minimization always works perfectly.
  • Press Alt+F4 when playing a match and you will immediately return to the frontend menu just like in WA. If you also press Alt+F4 in the frontend menu, WWP will shutdown.
Still having problems? Troubleshooting FAQ!
Spoiler! View
Q: When I start WWP, a black window appears, and then the game crashes with "WWP has stopped working" error.
A: Please ensure that:
  • You have installed the fix correctly.
  • All of the "Compatibility" options, like "Limited colour mode" are disabled. The game will not start if you force a 8-bit (256 color) or 16-bit color mode through the Compatibility options.
  • No other fixes are interfering with the module.


Credits:
  • menopem for his awesome d3dhook library from D3DWindower, otherwise this all wouldn't be possible!
  • VEG for adapting d3dhook to make it independent with a settings file (wndmode).
  • Kawoosh for the original white-fields-fix solution and the WormKitDS loader.
  • StepS for further working and supporting the fix updates specifically for WWP/W2/WA after Kawoosh's solution, and making ReSolution.
  • S*natch/des for their original Worms 2 HD patches. Thanks to that I was motivated to create ReSolution for Worms 2 and WWP!
« Last Edit: January 10, 2017, 09:48 PM by StepS »
Dec 30 2013 23:59:44 <StepS> windowed mode isn't the only thing you need about frontend
Dec 30 2013 23:59:49 <StepS> you need it to be actually bigger
Dec 31 2013 00:00:13 <StepS> it actually is very small on my 15-inch full HD screen
Dec 31 2013 00:00:25 <StepS> while running at 640x480 or stretched mode makes it fuzzy
Dec 31 2013 00:00:44 <StepS> this problem has been around since the Worms Armageddon's release and no one has even tried to beat it
[...]

Offline avirex

Re: [Moved] A real compatibility fix for WWP (XP, Vista, 7, 8)
« Reply #1 on: June 12, 2013, 01:51 AM »
cool...

but had anyone requested for this? are people going to start paying wwp?


Offline StepS

Re: [Moved] A real compatibility fix for WWP (XP, Vista, 7, 8)
« Reply #2 on: June 12, 2013, 09:21 AM »
cool...

but had anyone requested for this? are people going to start paying wwp?

People commenting
http://puu.sh/3dVPu.png
Almost 700000 visitors in 4 years

And about 600 new different people visiting every day...
WWP definitely still got its reputation...
« Last Edit: June 12, 2013, 11:43 AM by StepS »
Dec 30 2013 23:59:44 <StepS> windowed mode isn't the only thing you need about frontend
Dec 30 2013 23:59:49 <StepS> you need it to be actually bigger
Dec 31 2013 00:00:13 <StepS> it actually is very small on my 15-inch full HD screen
Dec 31 2013 00:00:25 <StepS> while running at 640x480 or stretched mode makes it fuzzy
Dec 31 2013 00:00:44 <StepS> this problem has been around since the Worms Armageddon's release and no one has even tried to beat it
[...]

Offline LeTotalKiller

Re: [WWP] A real compatibility fix for Vista, 7, 8 and XP
« Reply #3 on: June 12, 2013, 10:49 AM »
Does that also solve the in-game color problem I used to have (and I'd still probably have if I reinstalled WWP on this new HDD)?

Offline StepS

Re: [WWP] A real compatibility fix for Vista, 7, 8 and XP
« Reply #4 on: June 12, 2013, 11:02 AM »
Don't forget to remove all the other "color fixes" you installed before! They are not needed as the game is in 32-bit colour depth now.
Dec 30 2013 23:59:44 <StepS> windowed mode isn't the only thing you need about frontend
Dec 30 2013 23:59:49 <StepS> you need it to be actually bigger
Dec 31 2013 00:00:13 <StepS> it actually is very small on my 15-inch full HD screen
Dec 31 2013 00:00:25 <StepS> while running at 640x480 or stretched mode makes it fuzzy
Dec 31 2013 00:00:44 <StepS> this problem has been around since the Worms Armageddon's release and no one has even tried to beat it
[...]

Offline LeTotalKiller

Re: [WWP] A real compatibility fix for Vista, 7, 8 and XP
« Reply #5 on: June 13, 2013, 05:14 PM »
Aww, sorry for franpa'ing. But thanks.

Offline Chrizonic

Re: [WWP] A real compatibility fix for Vista, 7, 8 and XP
« Reply #6 on: June 16, 2013, 08:08 PM »
Regardless of the new games, WWP will always stand above all as the most addictive and fun. It has to be kept alive for as long as life still exists (?)
Thanks again for the fix!  :)

Offline LeTotalKiller

Re: [WWP] A real compatibility fix for Vista, 7, 8 and XP
« Reply #7 on: June 16, 2013, 08:35 PM »
Regardless of the new games, WWP will always stand above all as the most addictive and fun. It has to be kept alive for as long as life still exists (?)
Thanks again for the fix!  :)

There's an exception to that though, the gewd ol' Worms Armageddon. :D

Offline Chrizonic

Re: [WWP] A real compatibility fix for Vista, 7, 8 and XP
« Reply #8 on: June 16, 2013, 09:06 PM »
Regardless of the new games, WWP will always stand above all as the most addictive and fun. It has to be kept alive for as long as life still exists (?)
Thanks again for the fix!  :)

There's an exception to that though, the gewd ol' Worms Armageddon. :D

True that. Not even the name can be beaten.

Offline mbernal131

Re: [WWP] A real compatibility fix for Vista, 7, 8 and XP
« Reply #9 on: June 27, 2013, 11:39 PM »
Hello!!!

I'm hoping someone can help. I've downloaded the patch for Win7 and the game finally launches!!!

My problem is that I can only see maybe 3/4ths of the screen. I have fiddled with my screen resolution and followed the troubleshooting steps above, and no dice. . .

Really hoping to get some help as me and my friends lan WWP every week and I need to be ready to kick some ass. :)

Offline LeTotalKiller

Re: [WWP] A real compatibility fix for Vista, 7, 8 and XP
« Reply #10 on: June 28, 2013, 04:40 AM »
Did you try the windowed mode? You can toggle it in the INI file, 0=off and 1=on.

Offline StepS

Re: [WWP] A real compatibility fix for Vista, 7, 8 and XP
« Reply #11 on: June 28, 2013, 11:10 PM »
Hello!!!

I'm hoping someone can help. I've downloaded the patch for Win7 and the game finally launches!!!

My problem is that I can only see maybe 3/4ths of the screen. I have fiddled with my screen resolution and followed the troubleshooting steps above, and no dice. . .

Really hoping to get some help as me and my friends lan WWP every week and I need to be ready to kick some ass. :)
can you describe the problem in detail? can you make a video or do screenshots to show what you mean?
Dec 30 2013 23:59:44 <StepS> windowed mode isn't the only thing you need about frontend
Dec 30 2013 23:59:49 <StepS> you need it to be actually bigger
Dec 31 2013 00:00:13 <StepS> it actually is very small on my 15-inch full HD screen
Dec 31 2013 00:00:25 <StepS> while running at 640x480 or stretched mode makes it fuzzy
Dec 31 2013 00:00:44 <StepS> this problem has been around since the Worms Armageddon's release and no one has even tried to beat it
[...]

Offline mbernal131

Re: [WWP] A real compatibility fix for Vista, 7, 8 and XP
« Reply #12 on: June 29, 2013, 12:53 AM »
When I try just a clean install, the game launches with no visible video

Test 1: Clean install of worms with wrapper installed. .

http://screencast.com/t/6TCdAOMj

Note that although it's only recording the worms as a small box, in actuallity it's a full screen view on my side, but I can only see whats in that small box.


Test 2: When I change WindowedFrontEnd to 1, then on my end, it displays exactly how you see it in the screenrecording above and I can see all of the game, however it's as if it's displaying smaller then what my system thinks it is. In otherwords, I have to move my mouse to the far bottom/left of my entire screen to choose settings, but when I click, nothing happens. I've also changed "WindowedInGame" and it's simply the same result, on the small window you see above is full screen.

Now, I've messed around with the windmode file and the best I've gotten is the game will launch small (about a quarter of the size of the screen), but when I click to play a game, it expands way to big. In otherwords the app window is at least 2x bigger then the screen. It appears that no matter what mode i'm in, worms will change my screen resolution to 640 when it is 2500 by default. So at the end of every test I must manually change my resolution back to normal. If i do that while the game is running, the game will simply stop displaying properly.

Here are the settings:

[WWPSettings]
WindowedFrontend=1
WindowedInGame=0

[WWPCompatibilitySettings]
; --------------------------------------------------
; -------------------- WARNING! --------------------
; --------------------------------------------------
; Do NOT enable these settings if not advised by FAQ!
; These settings are ONLY for a few people who are
; experiencing problems not present on all systems.
; Please check the FAQ for rare problems that may
; occur. In particular, it is not advised to enable
; these settings because they lead to loss of some
; features that exist in the module, for example the
; ability to minimize the game. Please consult StepS
; if you are unsure in what you may need to enable.
; --------------------------------------------------
AlternativeWhiteFieldsFix=1
Force1024x768InGame=1
UnhideT17WindowInGame=1

[WINDOWMODE]
; --------------------------------------------------
; Do NOT change anything here if you don't know what
; you're doing! In particular, do not enable the
; window border as it won't work as expected!
; --------------------------------------------------
UseGDI=0
UseDirect3D=0
UseDirectInput=0
UseDirectDraw=1
UseDDrawColorEmulate=1
UseDDrawFlipBlt=0
UseDDrawColorConvert=1
UseDDrawPrimaryBlt=1
UseDDrawAutoBlt=0
UseDDrawEmulate=1
UseDDrawPrimaryLost=0
UseCursorMsg=0
UseCursorSet=0
UseCursorGet=0
ImproveSpeed=1
UseBackgroundResize=0
UseForegroundControl=1
UseFGCGetActiveWindow=0
UseFGCGetForegroundWindow=0
UseFGCFixedWindowPosition=0
EnableExtraKey=0
ShowFps=0
UseCursorClip=1
UseBackgroundPriority=0
DDrawBltWait=-1
Border=1

Offline StepS

Re: [WWP] A real compatibility fix for Vista, 7, 8 and XP
« Reply #13 on: June 29, 2013, 12:58 PM »
ah what a coincidence, I also use 150% dpi scaling but didn't meet these problems. Btw, WindowedFrontend and WindowedInGame are of course for two separate things: the first for the menus, the second for the actual gameplay (so it will change resolution there).
btw you should not enable Border, because it doesn't work as it should and breaks some things. if Border support was to be added, it would only work InGame due to the problems made in 2001 by Team17.
also in your case you should disable all of the WWPCompatibilitySettings; none of them applies to you.

now to DPI scaling. It probably scales some apps that it shouldn't, like WWP in this case.
Disclaimer: I don't know the English labels for the sections explained below, so you'll have to check it out.
So try either:
- go into WWP.exe properties, "Compatibility" tab, then check "Disable dpi scaling on high screen resolutions"
If it doesn't work, then:
- right click the desktop, "Screen resolution", then "Changing size of text and other elements". Choose "User-defined size parameters". Make sure that the "Use Windows XP scaling styles" is enabled. This option is there to prevent scaling some apps it shouldn't scale. In your case it's WWP; it scaled its entire interface thinking that it's merely a dialog window (in fact it is, but we have to blame Team17 for such a poor implementation). Which was a mistake.
« Last Edit: June 29, 2013, 01:02 PM by StepS »
Dec 30 2013 23:59:44 <StepS> windowed mode isn't the only thing you need about frontend
Dec 30 2013 23:59:49 <StepS> you need it to be actually bigger
Dec 31 2013 00:00:13 <StepS> it actually is very small on my 15-inch full HD screen
Dec 31 2013 00:00:25 <StepS> while running at 640x480 or stretched mode makes it fuzzy
Dec 31 2013 00:00:44 <StepS> this problem has been around since the Worms Armageddon's release and no one has even tried to beat it
[...]

Offline mbernal131

Re: [WWP] A real compatibility fix for Vista, 7, 8 and XP
« Reply #14 on: June 29, 2013, 02:36 PM »
now to DPI scaling. It probably scales some apps that it shouldn't, like WWP in this case.
Disclaimer: I don't know the English labels for the sections explained below, so you'll have to check it out.
So try either:
- go into WWP.exe properties, "Compatibility" tab, then check "Disable dpi scaling on high screen resolutions" . . .

YOUR THE MAN!!!!  :D ;D :D ;D :D ;D :D ;D :D ;D :D ;D :D ;D :D ;D

This was EXACTLY the issue. Once I disabled DPI scaling the game plays just like it did on my old XP machine.

As a side note, the weird thing about me enabling border before was that it actually helped me see the game. All previous wrapper settings failed, but as soon as I enabled border, I could at least see some of the screen. Weird huh?
  ???