Forums
May 28, 2020, 03:40 PM

Author Topic: Game stutters on Windows 10  (Read 264 times)

0 Members and 2 Guests are viewing this topic.

Offline Memox

Game stutters on Windows 10
« on: May 11, 2020, 02:55 AM »
I got a new gear lately, and WA seems to be the only game affected by this problem...

I know this title is old and all, but somehow it's funny that a bulky PC, W7, integrated graphics and other obsolete components managed to do a better work than my current PC (well it's not that weird actually, but still)... That's beside the point; I was wondering if there's a way around this, because these stutters are very frequent both online and offline, and of course that's a big problem no matter the scheme. That's pretty much the reason why I'm not playing anymore, and it's a shame.

Thanks for your attention.
« Last Edit: May 11, 2020, 02:58 AM by Memox »
lemme suck ur worms real quick ok? no homo

Offline XanKriegor

Re: Game stutters on Windows 10
« Reply #1 on: May 11, 2020, 03:12 AM »
Allow WA use only one CPU core. This helped some people already, inc. me.

Offline WTF-8

Re: Game stutters on Windows 10
« Reply #2 on: May 11, 2020, 03:13 PM »
"slutter" is a rather vague term. I don't see any more info I can work with, so I'll go with standard suggestions of changing graphics renderer (usually you want Direct3D 9) and trying out different vertical synchronization modes. Main Menu -> Options -> Advanced -> Graphics

Offline Sensei

Re: Game stutters on Windows 10
« Reply #3 on: May 11, 2020, 06:41 PM »
Try these settings. They may get you rid of stutters.
Although, I get 1-2 mini freezes per game but got used to it by now. Sucks when it happens during rope turn tho.
Collection of twitch interviews, league clanners and CWT matches.



Click to join Worms Armageddon community on Discord Server!


Offline Jengu

Re: Game stutters on Windows 10
« Reply #4 on: May 12, 2020, 07:34 AM »
Try disabling fullscreen optimisations.
           

Offline Memox

Re: Game stutters on Windows 10
« Reply #5 on: May 13, 2020, 08:59 PM »
"slutter" is a rather vague term. I don't see any more info I can work with, so I'll go with standard suggestions of changing graphics renderer (usually you want Direct3D 9) and trying out different vertical synchronization modes. Main Menu -> Options -> Advanced -> Graphics

Not that vague actually... There aren't any other terms to describe it. It's a lag that happens independently from offline or online play. Perhaps micro-stuttering is a more correct terminology. I'll try your suggestions though.

Try these settings. They may get you rid of stutters.
Although, I get 1-2 mini freezes per game but got used to it by now. Sucks when it happens during rope turn tho.

Yeah it seems way better now. The main menu gave me epilepsy since the graphical effects are ridiculously faster now, but besides that I think I've noticed quite some difference. Thanks.

Allow WA use only one CPU core. This helped some people already, inc. me.

Care to explain how you do that? I've noticed that the CPU gets way too high for a game like this, and maybe stuff like that can do the trick besides helping with the original issue. Do you use third-party softwares to do that or it's some kind of "simpler" process?
lemme suck ur worms real quick ok? no homo

Offline XanKriegor

Re: Game stutters on Windows 10
« Reply #6 on: May 16, 2020, 06:24 PM »
Task Mamager - Details - right click - Set Affinity



Offline Thewolensheep

Re: Game stutters on Windows 10
« Reply #7 on: May 17, 2020, 09:15 AM »
If on Win10 I would recommend disabling Game Mode because as of now, it causes stuttering in all games and may cause freezes.

Just go to settings -> gaming -> game mode
Creates soundbanks and other s!@t.

Offline Yaotlac

Re: Game stutters on Windows 10
« Reply #8 on: May 20, 2020, 11:37 AM »
D3D9Wnd and AntiLag modules fixed my stutter issues on win 10, combined with direct 3d 9 shader chosen in game advanced options.

Re: Game stutters on Windows 10
« Reply #9 on: Today at 03:02 PM »
If on Win10 I would recommend disabling Game Mode because as of now, it causes stuttering in all games and may cause freezes.

Just go to settings -> gaming -> game mode

Thanks!