Forums
December 17, 2017, 08:00 AM

Author Topic: Black screen  (Read 306 times)

0 Members and 1 Guest are viewing this topic.

Offline Asbest

Black screen
« on: August 14, 2017, 07:30 PM »
After new windows update ( or without update, im not sure ) when i open WA it is shows black screen. What to do?



Offline STRGRN

Re: Black screen
« Reply #1 on: August 14, 2017, 07:41 PM »
wow racist

Offline TheKomodo

Re: Black screen
« Reply #2 on: August 14, 2017, 07:56 PM »
Just use:



https://www.tus-wa.com/files/file-1235/

"i have found STRainedGRoiN's flags and graves to be useful even for making music. now i can't even imagine creating a song without using content from this pack. 11/10"

Offline Kradie

Re: Black screen
« Reply #3 on: August 14, 2017, 08:44 PM »
Right click on WA.exe, select properties, check ''run this program in compatibility for'', choose Windows 8 or 7.

Doesn't work? Try download ''wkD3D9Wnd.dll'' and place it in your Worms Armageddon directory.
https://www.tus-wa.com/forums/worms-armageddon/d3d9wnd-0-7-a-native-direct3d-9-based-windowed-mode-and-multi-monitor-support-19063/

Offline Rabbzz

Re: Black screen
« Reply #4 on: August 15, 2017, 04:59 AM »
mine sometimes does this, other times its fine  :-X

Offline StepS

Re: Black screen
« Reply #5 on: August 15, 2017, 03:29 PM »
This seems to happen on Win 10 Creators Update with some NVIDIA cards when vsync is disabled in the game settings (and d3d9 is on).
One of the solutions: enable vsync in the game settings, but force-disable it in the NVIDIA control panel for WA. This may not feel the same as with the previous setup.

Another possible (untested!) solution: Right-click WA.exe, select Properties - Compatibility - "Disable full-screen optimizations". This is new and untested, and because I can not reproduce this issue on my system, I ask everyone who is/was affected by the issue to try this out (disable any of your current workarounds first). This may have something to do with the new Game Mode on Windows 10.
Edit: this doesn't work according to Asbest, FaD and Tiku.
« Last Edit: October 12, 2017, 05:49 PM by StepS »
Dec 30 2013 23:59:44 <StepS> windowed mode isn't the only thing you need about frontend
Dec 30 2013 23:59:49 <StepS> you need it to be actually bigger
Dec 31 2013 00:00:13 <StepS> it actually is very small on my 15-inch full HD screen
Dec 31 2013 00:00:25 <StepS> while running at 640x480 or stretched mode makes it fuzzy
Dec 31 2013 00:00:44 <StepS> this problem has been around since the Worms Armageddon's release and no one has even tried to beat it
[...]

Offline StepS

Re: Black screen
« Reply #6 on: October 12, 2017, 05:45 PM »
A new solution from FaD, confirmed to work by at least 2 people so far.
Enable Windows 8 or 7 compatibility mode in WA.exe properties.

Anyone affected by this issue should also try updating to the new Fall Creators Update and report the situation there.
« Last Edit: October 12, 2017, 05:49 PM by StepS »
Dec 30 2013 23:59:44 <StepS> windowed mode isn't the only thing you need about frontend
Dec 30 2013 23:59:49 <StepS> you need it to be actually bigger
Dec 31 2013 00:00:13 <StepS> it actually is very small on my 15-inch full HD screen
Dec 31 2013 00:00:25 <StepS> while running at 640x480 or stretched mode makes it fuzzy
Dec 31 2013 00:00:44 <StepS> this problem has been around since the Worms Armageddon's release and no one has even tried to beat it
[...]